Finally - Woodworking Talk - Woodworkers Forum
 
Thread Tools Display Modes
post #1 of 6 Old 05-21-2012, 02:08 PM Thread Starter
Senior Member
 
Join Date: Feb 2012
Posts: 997
View BigJoe16's Photo Album My Photos
Finally

I dont know if you remember my posts a while ago, like in February, but I was having problems with my lathe. it was eting belts up. I took it to the delta repair center and they said they had to wait to get the belts sent to them to look at it. Well its been 3 months so last week i went in there and picked it up unfished and not even looked at. I ordered some belts off eraplacementparts.com and gopt them today. Its was really nice being able to start turning again.
BigJoe16 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-21-2012, 02:52 PM
Trytore Member
 
Shop Dad's Avatar
 
Join Date: May 2011
Location: Central New Jersey
Posts: 2,764
View Shop Dad's Photo Album My Photos
Man, I keep hearing such terrible things about Delta service. That's just appalling! Is this company history?
Shop Dad is offline  
post #3 of 6 Old 05-21-2012, 03:10 PM
No Longer Here
 
Join Date: Feb 2009
Posts: 6,839
View rrbrown's Photo Album My Photos
I think it's a more of a problem with individual service centers. Same type stuff happens with other companies. Usually people just going to work to collect a check not to do there job.

Glad to hear your up and running again.
rrbrown is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 05-21-2012, 05:54 PM Thread Starter
Senior Member
 
Join Date: Feb 2012
Posts: 997
View BigJoe16's Photo Album My Photos
Yeah i agree the problem is with the local service centers. The man i talked to one the phone at delta was helpfull and knew what he was talking about. They said the belt it needed was on backorder and they told me a date they could get it but it just kept on getting pushed back. Finally I had enough and will just deal with the problem.
BigJoe16 is offline  
post #5 of 6 Old 05-23-2012, 08:46 AM
sawdust manufacturer
 
txpaulie's Avatar
 
Join Date: Jul 2010
Location: SE Texas
Posts: 581
View txpaulie's Photo Album My Photos
I had a one-year-old Delta 46-460 that had some power issues, took it to a local factory repair guy. It was not going to be fixed for "months"...
Called the company, they said, "try to return it to the retailer"...

I did, and will thank Rockler of Houston for their help in the matter!

I use a Jet now.

p

...ever notice how "I'm sorry" and "I apologize" mean the same thing, unless you are at a funeral..?
txpaulie is offline  
post #6 of 6 Old 05-23-2012, 03:49 PM Thread Starter
Senior Member
 
Join Date: Feb 2012
Posts: 997
View BigJoe16's Photo Album My Photos
Thats what im thinking of doing, using JET. I would really like a 14/42 lathe but i cant really justify buying one now. Or have the money.
BigJoe16 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Woodworking Talk - Woodworkers Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally! Shop Dad Power Tools & Machinery 5 04-06-2012 03:49 PM
It's finally here and set up! rrbrown Power Tools & Machinery 19 02-09-2011 02:06 AM
Finally Got My Fix djg Forestry & Milling 10 10-12-2010 11:28 AM
New saw is finally here! F3RR3T Power Tools & Machinery 7 02-02-2010 01:49 AM
Finally got a DC garryswf Power Tools & Machinery 0 12-01-2009 12:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome